Degraded system performance as our DNS and CDN Cloudflare is facing issues
Incident Report for Demodesk
Resolved
Cloudflare resolved their incident and Demodesk is fully back to normal operation. Details on their outage can be found here: https://www.cloudflarestatus.com/incidents/xvs51y9qs9dj
Posted Jun 21, 2022 - 08:24 UTC
Monitoring
We mitigated the major impact and the core functionality our system is restored.

Since Cloudflare is widely spread we also see errors in our communication with third party integrations (eg. Hubspot).
Posted Jun 21, 2022 - 07:34 UTC
Investigating
We see issues with various parts of the system. The root cause is an incident of Cloudflare (https://www.cloudflarestatus.com/).
Posted Jun 21, 2022 - 07:07 UTC
This incident affected: Authentication & API Gateway and Scheduling (Scheduling, Customer Booking Pages).