CDN outage

Incident Report for Demodesk

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:04 UTC

Monitoring

It looks like the issue has been resolved. We'll continue to monitor.
Posted Nov 18, 2025 - 12:09 UTC

Identified

Our CDN provider Cloudflare has an ongoing issue and some customers might not be able to connect to Demodesk at the moment. Cloudflare is tracking the incident here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7 We're monitoring the situation and will provide updates as soon as possible.
Posted Nov 18, 2025 - 11:59 UTC