Delayed demo starts for some customers

Incident Report for Demodesk

Resolved

This incident has been resolved and we identified specific ways to prevent this from happening again which will be implemented.
Posted Nov 26, 2020 - 11:29 UTC

Monitoring

We identified issues in our networking configuration and were able to fix the issues. We're currently monitoring the configuration change and identify the next steps to prevent this error in the future.
Posted Nov 26, 2020 - 11:16 UTC

Investigating

We are currently investigating this issue.
Posted Nov 26, 2020 - 09:05 UTC
This incident affected: Demodesk Meet (Screen sharing, Conferencing).