Google has an active incident for their Calendar API
Incident Report for Demodesk
Resolved
This incident has been resolved.
Posted Sep 21, 2023 - 16:09 UTC
Identified
Google Calendar is having issues. Demodesk functionalities that read or write into Google Calendars might not work as expected.

Google shares status updates and details on their status page here: https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 14:40 UTC
This incident affected: Scheduling (Scheduling, Customer Booking Pages).